0844 277 277 Mon-Fri 8am-6pm
CSS Insurance

App-Support

Many thanks for your interest in our apps. Please let us know your problem, and we will then get in touch by mail or phone.

Is the software on your smartphone / tablet up to date?

The myCSS app requires at least version 10 for iOS and 5.0 for Android to run.

It couldn't be easier:
iOS: Tap on «Settings > General > Software update»
Android: Tap on «Settings > About device > Software updates»


Question about app










Available number of characters:

Personal details











Did you know?

Problems with an app are generally related to the device (Apple or Android) and the version you have installed. Please provide us with all of this information.

Have you checked whether or not a new version is already available in the store? We make every effort to continue improving our apps.